Вопрос по информатике:
составить программу в паскале! 9 класс! СРОЧНО!!! Написать программу, по длинам сторон распознающую среди всех треугольников ABC прямоугольные. Если таких нет, то вычислить величину угла С.
- 14.01.2018 17:07
- Информатика
- remove_red_eye 10762
- thumb_up 49
Ответы и объяснения 1
const Radian = 57.295779513; //Сколько градусов в одном радиане
var
a, b, c: real; //Стороны, лежащие против углов A, B и C соответственно
begin
writeln('Введите 3 стороны треугольника в следующем порядке: a, b, c');
readln(a, b, c);
if (sqr(a) = sqr(b) + sqr(c)) or (sqr(b) = sqr(a) + sqr(c)) or (sqr(c) = sqr(a) + sqr(b)) then writeln('Треугольник ABC - прямоугольный') {Если хотя бы для одной из сторон выполняется теорема Пифагора, то данный треугольник прямоугольный}
else writeln('Угол C равен: ', arccos((sqr(a) + sqr(b) - sqr(c)) / (2 * a * b)) * Radian, ' градусов'); {Выражаем из теоремы косинусов косинус угла C, берем arccos от него и умножаем получившееся значение на количество градусов в радиане, чтобы получить ответ в градусах}
end.
Пользоваться компилятором Pascal ABC.Net, потому что это единственный компилятор из всех известных мне, который поддерживает функцию arccos.
Если будут вопросы, спрашивай.
- 15.01.2018 10:15
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.