Вопрос по информатике:
Написать программу определения суммы цифр числа и их количества, используя оператор цикла с постусловием.
Программа Паскаль
- 13.04.2018 10:38
- Информатика
- remove_red_eye 8254
- thumb_up 40
Ответы и объяснения 1
Program gt;
var n,q,s,k:integer;
begin
read(n);
s:=0;
k:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
k:=k+1;
end;
writeln(s,' ',k);
end.
- 14.04.2018 17:01
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.