Вопрос по информатике:
Пожалуйста помогите написать программу и составить блоксхему !
Определить среди 3 введенных чисел сумму отрицательных и положительных.Если больше сумма положительных,то найти минимум из этих 3 чисел , а иначе найти максимум.
- 01.03.2018 08:10
- Информатика
- remove_red_eye 19382
- thumb_up 44
Ответы и объяснения 2
Uses crt;
var sump,sumn,i:integer;
a:array[1..3] of integer;
begin
for i:=1 to 3 do
begin
read(a[i]);
if a[i]>=0 then
sump:=sump+a[i]
else
sumn:=sumn+a[i];
end;
if sump>=sumn then
writeln(min(min(a[1],a[2]),min(a[2],a[3])))
else
writeln(max(max(a[1],a[2]),max(a[2],a[3])));
end.
- 02.03.2018 04:23
- thumb_up 30
М... заморила твоя задача однако
Program asd;
USES crt;
var
A:array [1..5] of integer;
min,max,min2,o,p:real;
i,n:integer;
Procedure max1;
begin
for i:=1 to 5 do
if A[i]>0 then
if minmin:=A[i];
Writeln('Min: ',min);
end;
Procedure min1;
begin
for i:=1 to 5 do
if A[i]<0 then
if min>A[i] then
min:=A[i];
Writeln('Min: ',min);
end;
BEGIN
clrscr;
For i:=1 to 5 do
begin
A[i]:=random(9)-5;
Write(' ',A[i]);
end;
Writeln;
//Otrizanie
For i:=1 to 5 do
if A[i]<0 then o:=o+A[i];
Writeln('Summa otrizatelnyx elementov: ',o);
//Polowitelnye
For i:=1 to 5 do
if A[i]>0 then p:=p+A[i];
Writeln('Summa polowitelnyx elementov: ',p);
if p
END.
- 03.03.2018 07:00
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.