Вопрос по информатике:
Помогите пожалуйста задачу сделать в паскале.
Составьте программу, которая удаляет из слова X те буквы, которые встречаются в слове Z. Слова X и Z вводятся с клавиатуры.
- 06.10.2017 02:53
- Информатика
- remove_red_eye 14912
- thumb_up 39
Ответы и объяснения 1
var
x,z:string;
i:integer;
ar:array['а'..'я'] of boolean;
begin
readln(x);
readln(z);
for i:=1 to Length(z) do
ar[z[i]]:=true;
for i:=Length(x) downto 1 do
if (ar[x[i]] = true) then delete(x,i-1,1);
writeln(x);
end.
Не забудь отметить лучший ответ ;-)
- 07.10.2017 08:38
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.