Вопрос по информатике:
(Составить программу по Pascal)
Дано двузначное число.
Определить, кратна ли сумма его цифр 6.
Подсказка:
Нужно отделить от числа единицы и десятки. Чтобы узнать, сколько десятков в
числе, нужно поделить число нацело на 10. Результат присвоить какой-нибудь
переменной. Затем исходное число поделить с помощью команды MOD на 10 и
результат записать в другую переменную.
- 19.01.2018 01:18
- Информатика
- remove_red_eye 6077
- thumb_up 44
Ответы и объяснения 1
Program zad6;
var n, d, e, s: integer;
begin
readln (n);
d:=n div 10;
e:= n mod 10;
s:=d+e;
if s mod 6=0 then writeln (' сумма цифр числа кратна 6') else writeln (' сумма цифр числа не кратна 6');
end.
- 21.01.2018 00:07
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.