Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел, оканчивается на 2.
Программа получает на выходе количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется числа, оканчивающиеся на 2
Количество чисел не превышает 1000. Введённые числа не превышают 30 000
Программа должна ввести одно числа - максимальное число, оканчивающиеся на 2
- 06.11.2017 20:59
- Информатика
- remove_red_eye 16385
- thumb_up 18
Ответы и объяснения 1
Var
n,i,max,num:integer;
begin
readln(n);
for i:=1 to n do begin
readln(num);
if (num mod 10=2) and (num > max)
then max:=num;
end;
writeln(max);
end.
- 07.11.2017 14:27
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.