Вопрос по информатике:
Помогите пожалуйста.
Дано целое трехзначное число a. Получить утроенное значение числа, состоящего из цифр числа a, записанных в неубывающем порядке.
Входные данные:Во входном потоке записано единственное целое трехзначное число a.
Выходные данные:В выходной поток вывести единственное целое число.
Пример входного файла (input.txt):748
Пример выходного файла (output.txt):1434
- 14.09.2017 09:21
- Информатика
- remove_red_eye 13361
- thumb_up 25
Ответы и объяснения 2
uses crt;
var i,j,n:integer;
a:string;
t:char;
begin
read(a);
for i:=1 to length(a) do
for j:=1 to length(a)-i do
if a[j]>a[j+1] then
begin
t:=a[j];
a[j]:=a[j+1];
a[j+1]:=t;
end;
writeln(3*strtoint(a));
end.
- 15.09.2017 19:21
- thumb_up 7
Uses crt;
var a,b,q,i:integer;
x: array [1..3] of integer;
input,output:text;
begin
assign(input,'input.txt');
assign(output,'output.txt');
reset(input);
readln(input,a);
x[1]:=a mod 10;
x[2]:=a div 10 mod 10;
x[3]:=a div 100;
for i:=2 to 3 do
if x[i]
x[i]:=x[i-1];
x[i-1]:=q;
end;
b:=100*x[1]+10*x[2]+x[3];
writeln(output,3*b);
close(input);
close(output);
end.
- 16.09.2017 14:05
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.