Вопрос по информатике:
напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6. Заполнить данный массив с клавиатуры, найти и вывести наименьшую нечетную сумму двух соседних элементов массива.
- 03.03.2018 00:55
- Информатика
- remove_red_eye 14210
- thumb_up 29
Ответы и объяснения 1
Program lol;
Const n=6;
var a:array [1..n] of integer;
i,s:integer;
begin
begin
for i:=1 to n do
readln (a[i]);
end;
s:=a[1]+a[2];
for i:=2 to n do
begin
if s>(a[i]+a[i-1]) then
s:=a[i]+a[i-1];
end;
writeln (s);
end.
- 03.03.2018 09:49
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.