Вопрос по информатике:
N - Factorial - это произведение всех чисел от 1 до N. Для заданного числа N определите, сколько нулей в конце десятичной записи N - Factorial
- 04.05.2016 13:18
- Информатика
- remove_red_eye 13521
- thumb_up 26
Ответы и объяснения 2
#includeusing namespace std;int main(){ int a,q=0,b=1,r; cin>>a; for(int i=1;i<=a;i++) b*=i; r=b; while(r!=0) {if(r%10==0) q++; else {cout<
- 05.05.2016 01:14
- thumb_up 32
Нужно посчитать количество 5 в разложении. Причем нужно учесть, что
25 = 5*5 - это две 5, а 125 = 5*5*5 - это три 5, и так далее.
BEGIN
k := 0;
for i=1 to N do
begin
a := i;
while a > 0 do
begin
if a mod 5 = 0 then
begin
k := k+1;
a := a/5;
end;
else a := 0;
end;
end;
writeln (k);
END.
Проверь. 25! должен заканчиваться 6 нулями.
- 06.05.2016 20:41
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.