Вопрос по информатике:
Числа
Вам даны число N и цифра D. Выведите все N-значные числа, которые не содержат цифру D, в возрастающем порядке.
Формат входных данных
В единственной строке входного файла записаны число N (1 ≤ N ≤ 7) и цифра D (0 ≤ D ≤ 9).
Формат выходных данных
В выходном файле выведите все N-значные числа, которые не содержат цифру D, по одному в одной строке.
- 12.06.2018 20:05
- Информатика
- remove_red_eye 1954
- thumb_up 39
Ответы и объяснения 1
Uses crt;
var n,d,z,x,c,k,a,b:integer;
begin
write('N:'); readln(n);
write('D:'); readln(d);
a:=round(power(10,n-1));
b:=round(power(10,n)-1);
for x:=a to b do
begin
z:=x;
k:=0;
while z>0 do
begin
c:=z mod 10;
if c=d then inc(k);
z:=z div 10;
end;
if k=0 then writeln(x);
end;
end.
- 13.06.2018 00:23
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.