Вопрос по информатике:
Определите средний балл всех учащихся по каждому предмету.
Формат входных данных Заданы сначала количество учащихся n, затем n строк, каждая из которых содержит фамилию, имя и три числа (оценки по трем предметам: математике, физике, информатике). Данные в строке разделены одним пробелом. Оценки принимают значение от 1 до 5.
Формат выходных данных Выведите три действительных числа: средний балл всех учащихся по математике, по физике, по информатике.Пример
Ввод Вывод
4 4.75 3.75 4.5
Ivanov Vasiliy 5 3 4
Petrov Sergey 4 3 5
Konstantinov Nikolay 5 5 5
Kuznetsov Ivan 5 4 4
Задачу написать на паскале
- 04.10.2017 10:36
- Информатика
- remove_red_eye 19839
- thumb_up 29
Ответы и объяснения 1
Var
n,i, j, a, b, d:integer;
a1, b1, d1:real;
c:char;
begin
read (n);
for i:=1 to n do begin
for j:=1 to 2 do
while c' ' do read (c);
read (a); a1:=a1+a;
read (b); b1:=b1+b;
read (d); d1:=d1+d;
end;
write (a1/n, ' ', b1/n, ' ', d1/n);
end.
где а1 - сумма оценок по первому предмету, в1 - по второму и т.д.
- 05.10.2017 23:38
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.