Вопрос по информатике:
Написать программу в паскаль ABC. Теорема Ферма утверждает, что не существует решения в целых числах уравнения x^n+y^n=z^n при n>2.
напишите программу, которая проверяла бы это утверждение при заданном n для всех x,y и z меньших 100.
- 06.09.2017 10:30
- Информатика
- remove_red_eye 10405
- thumb_up 36
Ответы и объяснения 1
Если n небольшие, то можно написать так:
var
x, y, z, n: integer;
disproved: boolean;
begin
write('Введите n: ');
readln(n);
disproved := false;
for x := 1 to 100 do
for y := 1 to 100 do
for z := 1 to 100 do
if power(x, n) + power(y, n) = power(z, n) then
begin
writeln('Ферма ошибся! ', x, ' ^ ', n, ' + ', y, ' ^ ', n, ' = ', z, ' ^ ', n);
disproved := true;
end;
if not disproved then
writeln('Теорема не опровергнута');
end.
При больших n уже придётся использовать длинную арифметику.
- 07.09.2017 14:17
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.