Вопрос по информатике:
Составить программу для нахождения корней квадратного уравнения ах2+вх+с
- 13.10.2017 19:20
- Информатика
- remove_red_eye 16383
- thumb_up 51
Ответы и объяснения 1
Uses crt;
var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.
- 14.10.2017 11:58
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.