Вопрос по информатике:
Составить программу которая поставит максимальный элемент массива на первое место(массив из 10 целых случайных чисел)
- 21.07.2015 16:37
- Информатика
- remove_red_eye 1539
- thumb_up 8
Ответы и объяснения 1
Var
i,max,m:integer;
a:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
begin
a[i]:=random(50);
write(a[i],' ');
if a[i]>max then
begin
max:=a[i];
m:=i;
end;
end;
writeln;
writeln('Измененный массив:');
i:=a[1];
a[1]:=a[m];
a[m]:=i;
for i:=1 to 10 do write(a[i],' ');
end.
- 22.07.2015 22:12
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.