Вопрос по информатике:
Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените все отрицательные элементы максимальным. Выведите на экран исходный и измененный массивы.
- 13.05.2015 17:51
- Информатика
- remove_red_eye 4687
- thumb_up 36
Ответы и объяснения 1
var
i,max:integer;
ar:array[0..200] of integer;
begin
randomize;
max:=0;
for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
writeln();
for i:=1 to 200 do begin
if (ar[i] < 0) then ar[i]:=max;
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
end.
- 14.05.2015 17:29
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.