Вопрос по информатике:
Нужно написать 2 программы желательно в PASCAL ABC
Программа 2. Пользователь вводит две целые переменные a, b. Написать программу для выполнения следующих операций:
1 вычислить результат целочисленного деления a на b;
2 вычислить результат деления a на b;
3 вычислить результат деления a на b, вывести его дробную часть;
4 вычислить результат деления a на b, вывести его целую часть;
5 вычислить результат деления a на b, округлить его.
Программа 3. Предложите пользователю ввести трехзначное число, сохраните это число в одну целочисленную переменную, переверните цифры в этом числе.
- 22.03.2018 14:55
- Информатика
- remove_red_eye 13810
- thumb_up 79
Ответы и объяснения 1
1 задание.
uses crt;
var
a, b : real;
begin
readln (a, b);
writeln (a/b);
writeln (frac(a/b));
writeln (int(a/b));
writeln (round(a/b));
readkey;
end.
2 задание.
uses crt;
var
a: integer;
st, st1, st2, st3: string;
begin
readln (a);
str (a, st);
st1:=st[3];
st2:= st[2];
st3:= st[1];
st:= st1+st2+st3;
writeln (st);
readkey;
end.
- 23.03.2018 07:11
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.