Вопрос по информатике:
1составьте программу ,вычисляющую сумму кубов первых n натуральных чисел
2Туристы в 1-ый день прошли 7км.В каждый следующий день они проходили на 1.5 км > .Составь программу ,вычисляющую сколько километров они пройдут за n дней.
Помогите срочно ,пожалуйста )))
- 05.09.2018 09:26
- Информатика
- remove_red_eye 17240
- thumb_up 22
Ответы и объяснения 1
1
const
n = 100;
var
a: array[1..n] of word;
i, m: byte;
sum: word;
begin
write('Kol-vo chisel: ');
readln(m);
sum:=0;
for i:=1 to m do
begin
a[i] := i;
write(a[i]:4);
sum:=sum + sqr(a[i])*a[i];
end;
writeln;
writeln('Sum = ', sum:4);
readln;
end.
2
const
n = 100;
var
a: array[1..n] of word;
i, dn: byte;
km: real;
begin
write('Kol-vo dney: ');
readln(dn);
km:=7;
for i:=2 to dn do
km:=km+(km+1.5);
writeln;
writeln('Turisty proshli ', km:4:1, ' km');
readln;
end.
- 06.09.2018 13:34
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.