Вопрос по информатике:
Составьте программу, которая заполняет массив a[1..8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями
- 27.06.2018 07:04
- Информатика
- remove_red_eye 19565
- thumb_up 15
Ответы и объяснения 1
Program z;
var
a:array[1..8] of integer;
i,k,s:integer;
begin
for i:=1 to 8 do
begin
a[i]:=random(9)+1;
end;
for i:=1 to 8 do
begin
if a[1] mod 2=0 then
k:=k+1
else
s:=s+a[i];
end;
writeln('Summa=',s);
writeln('Kol-vo=',k);
end.
- 28.06.2018 20:40
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.