Вопрос по информатике:
помогите пожалуйста...
Напишите программу по которой из текстового файла с именем kvur.txt будут прочитаны три числа: a,b,c - коэффициенты квадратного уравнения затем будут вычислены корни этого уравнения и выведены на экран и в текстовый файл korni.txt.
на паскале
- 18.11.2015 02:13
- Информатика
- remove_red_eye 5484
- thumb_up 27
Ответы и объяснения 1
Если данное уравнение не имеет корней, выведите число 0. Если уравнение имеет один корень, выведите число 1, а затем этот корень. Если уравнение имеет два корня, выведите число 2, а затем два корня в порядке возрастания. Если уравнение имеет бесконечно много корней, выведите число 3.
program gt;
var a,b,c,d,x1,x2,s:real;label 1,2;
begin
read(a,b,c);
if ((a=0)and(b=0)and(c0)) then writeln(0);
if(a=0)and(b=0)and(c=0)then writeln(3);
if(a0)and(b0)and(c0)then begin
d:=b*b-4*a*c;
if (d<0)or((a=0)and(b=0)and(c0)) then writeln(0);
if d>=0 then begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
if x1=x2 then write(1,' ',x1);
if (x1x2)and(x1
end;
end;
if (a=0)and(b0)and(c0)then begin
x1:=-c/b;
write(1,' ',x1);
end;
if (a0)and(b=0)and(c0)then begin
if(-c/a>=0) then begin
x2:=sqrt(-c/a);
x1:=-sqrt(-c/a);
if (x1x2)and(x1
end;
if(-c/a<0) then writeln(0);
end;
if (a0)and(b0)and(c=0)then begin
x1:=0;
x2:=-b/a;
if (x1x2)and(x1
end;
end.
- 19.11.2015 17:14
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.