Вопрос по информатике:
Найдите трехзначное число, равное сумме десятков, квадрата цифры сотен и куба цифры единиц, напишите программу пожалуста
- 02.06.2018 01:40
- Информатика
- remove_red_eye 3384
- thumb_up 49
Ответы и объяснения 1
Uses crt;
var i,s,e,d,so:integer;
begin
for i:=100 to 999 do
begin
e:=i mod 10;
d:=(i div 10) mod 10;
so:=i div 100;
s:=d+so*so+e*e*e;
if i=s then writeln(i);
end;
end.
- 03.06.2018 12:41
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.