Вопрос по информатике:
Посчитать количество предложений в файле(тема:строковый тип данных).т.е написать программу
- 04.03.2016 12:01
- Информатика
- remove_red_eye 17682
- thumb_up 50
Ответы и объяснения 1
Не работает с многоточием, если что.
var f:text; c:char; k:integer;
begin
k:=0;
assign(f,'input');
reset(f);
while eof(f)=false do
if eoln(f) then readln(f)
else
begin
read(f,c);
if (c='.') or (c='!') or (c='?') then k:=k+1;
end;
if not((c='.') or (c='!') or (c='?')) then k:=k+1;
close(f);
write(k)
end.
- 05.03.2016 06:30
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.