Вопрос по информатике:
Составьте программу, которая заполняет массив а[1...8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значения.
- 18.08.2018 14:08
- Информатика
- remove_red_eye 13354
- thumb_up 28
Ответы и объяснения 1
Program Zadacha;
Var a: Array [1..8] of Integer;
i, b, c: Integer;
Begin
Randomize;
For i := 1 To 8 Do
a[i] := Random(11);
b := 0;
c := 0;
For i := 1 To 8 Do
Begin
If a[i] Mod 2 = 1 Then
b := b + 1
Elsec := c + a[i];
End;
WriteLn('Количество нечетных элементов массива равно ', b);
WriteLn('Сумма четных элементов массива равна ', c);
ReadLn;
End.
- 19.08.2018 20:42
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.