Вопрос по информатике:
Составить программу в паскале для 8 класса, без array пожалуйста, задача: найти кол-во четных цифр числа, тема - разработка алгоритма содержащего цикл с условием, тоесть с while, do, begin ну тоесть их испобьзовать, вот так составить программу по задаче
- 02.04.2018 15:40
- Информатика
- remove_red_eye 4199
- thumb_up 12
Ответы и объяснения 1
Самое простое что придумал)))
uses crt;
var
i,a,s:integer;
begin
write('vvedite 4islo: ');
read(a);
s:=0;
while a>=1 do
begini:=a mod 10;
a:=a div 10;
if i mod 2=0 then
s:=s+1;
end;
write('kolvo 4etnblx=',s);
read;
end.
смысл программы:делит число на 10 и проверят четный остаток или нет, и следовательно четная это была цифра или нет)))
- 03.04.2018 02:47
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.