Вопрос по информатике:
Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные: Два числа N(1<N&l
- 12.08.2015 15:53
- Информатика
- remove_red_eye 18587
- thumb_up 48
Ответы и объяснения 1
Var k, j, sum:integer;
n,i:longint;
prev,cur, found :boolean;
s:string;
Begin
read(n,k);
for i := 2 to n do begin
s := inttostr(i);
sum := 0;
for j := 1 to length(s) do
sum := sum + strtoint(s[j]);
cur := (sum mod k) = 0;
found := found or (prev and cur);
if prev and cur then
writeln(i - 1,' ',i);
prev := cur;
end;
if not found then writeln('NO');
End.
- 13.08.2015 08:22
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.