Вопрос по информатике:
Помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"
const
N=20;br />var
a:array [1..N] of intege
- 02.03.2018 17:20
- Информатика
- remove_red_eye 11243
- thumb_up 42
Ответы и объяснения 2
Я бы написал легче, но тут ошибка в цикле, после объявление цикла начни begin, а после if max>99 then... end; Именно ;""
- 03.03.2018 03:29
- thumb_up 14
const
N=20;
var
a:array [1..N] of integer;
i,j,max,k:integer;
begin
max:=99;
for i:= 1 to N do
begin
readln(a[i]);
j:=a[i];
for k:= 1 to N do
begin
if (j>99) and (j<999) and (j mod 9 0) and (j>max) then max:=j;
end;
end;
if max>99 then writeln (max) else writeln ('no');
end.
- 04.03.2018 20:15
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.