Вопрос по информатике:
Ребята, очень прошу помочь. Только не всё в одной проге, а сразу несколько. Составьте хоть две программы, очень нужно(
А. составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с четными значениями
Б.
составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет произведение элементов массива с нечётными значениями
В.
составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива
Г.
составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива с четными значениями.
- 11.08.2015 07:07
- Информатика
- remove_red_eye 1592
- thumb_up 29
Ответы и объяснения 1
1)
var a: array [1..10] of integer;
i, m: integer;
begin
for i := 1 to 10 do
begin
a[i] := random(20);
writeln('[', i, '] => ', a[i]);
if (a[i] mod 2 = 0) then m := m + a[i];
end;
writeln(m);
end.
2)
var a: array [1..10] of integer;
i, m: integer;
begin
m := 1;
for i := 1 to 10 do
begin
a[i] := random(20);
writeln('[', i, '] => ', a[i]);
if (a[i] mod 2 = 1) then m := m * a[i];
end;
writeln(m);
end.
3)
var a: array [1..10] of integer;
i, m: integer;
begin
m := 1;
for i := 1 to 10 do
begin
a[i] := random(20);
writeln('[', i, '] => ', a[i]);
m := m + a[i];
end;
writeln(m / 10);
end.
4)
var a: array [1..10] of integer;
i, m, c: integer;
begin
m := 1;
for i := 1 to 10 do
begin
a[i] := random(20);
writeln('[', i, '] => ', a[i]);
if (a[i] mod 2 = 0) then
begin
m := m + a[i];
c := c + 1;
end;
end;
if (c > 0) then writeln(m / c);
end.
Прошу Вас =)
- 12.08.2015 05:44
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.