Вопрос по информатике:
Составить программу вычисления суммы цифр 5-значного числа вводимого с клавиатуры где N вводиться с клавиатуры
- 22.01.2015 10:56
- Информатика
- remove_red_eye 13581
- thumb_up 38
Ответы и объяснения 1
Uses crt;
var s,i,x : integer;
begin
Read(x);
For i:=1 to 5 do begin
s:=s + (x mod 10);
x:=x div 10;
end;
Write (s);
end.
Язык - ПаскальABC
Если хочешь можешь еще сделать проверку на пятизначное число.
- 23.01.2015 15:38
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.