Вопрос по информатике:
Две целочисленный массив из 30 элементов . Элементы массива могут принимать целые значения о 0 до 100 -баллы учащихся выпускного класса за итоговый тестер информатике .составьте программу которая позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе ((( СРОЧнО))
- 19.07.2018 23:23
- Информатика
- remove_red_eye 15986
- thumb_up 18
Ответы и объяснения 1
const n=30;
var a: array[1..n] of integer;
i,k,sum: integer;
sr: real;
begin
randomize;
sum:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(101);
write(a[i],' ');
sum:=sum+a[i];
end;
sr:=sum/n;
writeln;
for i:=1 to n do if a[i]>sr then k:=k+1;
writeln(k);
end.
- 20.07.2018 14:08
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.