Вопрос по информатике:
1.Составьте программу заполнения массива НЕ ИСПОЛЬЗУЯ КЛАВИАТУРУ числами -2, 4,-6,8,-10...20.
2.Сформировать одномерный массив из 30 элементов (задаются ГСЧ-рандомно) из интервала -3..3. Массив вывести.Найти номер положительных элементов и их сумму чисел.
- 15.02.2018 01:35
- Информатика
- remove_red_eye 4788
- thumb_up 64
Ответы и объяснения 1
Буду считать, что да, он самый востребованный тут =)
1)
var a: array [0..9] of integer;
i, o: integer;
begin
for i := 1 to 20 do
begin
if (i mod 4 = 0) then a[o] := i
else if (i mod 4 = 2) then a[o] := -1 * i;
if (i mod 4 mod 2 = 0) then o := o + 1;
end;
for i := 0 to 9 do
writeln(a[i]);
end.
2)
var a: array [0..30] of integer;
i, o: integer;
s: string;
begin
for i := 1 to 30 do
begin
a[i] := random(6) - 3;
end;
writeln('Массив:');
for i := 0 to 30 do
begin
writeln('[', i, '] => ', a[i]);
if (a[i] > 0) then
begin
o := o + a[i];
s := s + inttostr(i) + ' ';
end;
end;
writeln('Номера положительных чисел: ', s);
end.
- 16.02.2018 10:10
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.