Вопрос по информатике:
Составьте программу,которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает: "число не трёхзначное" .
- 12.07.2016 22:55
- Информатика
- remove_red_eye 19997
- thumb_up 44
Ответы и объяснения 1
Решение на С/C++ :
#include
using namespace std;
int main()
{
int number;
cin>>number;
number=(number-number%10)/10;
//в результате остаётся число десятков, т.е. число без единиц
number=(number-number%10)/10; // тут уже число сотен без десятков
if(number==0) // если в результате будет 0 десятков, то выводим текст
{
cout<<"chislo ne trehznachnoe;br />}
else // в противном случае десятки будут
{
cout<
- 14.07.2016 09:11
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.