Вопрос по информатике:
ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!Решить задачи на турбопаскале:ХОТЯБЫ ПАРУ ШТУК
1.Дано натуральное число Найти сумму и произведение первых двух цифр.
2.Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.
3.Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.
- 15.01.2015 12:53
- Информатика
- remove_red_eye 13239
- thumb_up 23
Ответы и объяснения 1
Program Kasyanova98_1;
uses crt;
var n,nt,p:integer;
begin
writeln('*** Alphaues is thinking... ***');
write('Ok, введите натуральное число N = ');
readln(n);
nt:=n;
while nt>=10 do
begin
p:=nt;
nt:= nt div 10;
end;
writeln('Cумма первых двух цифр числа ',n,' равна ',(p div 10)+(p mod 10));
writeln('Произведение первых двух цифр числа ',n,' равно ',(p div 10)*(p mod 10));
end.
Program Kasyanova98_2;
uses crt;
var n,nt,sum,kw,temp:integer;
begin
writeln('*** Alphaues is thinking... ***');
write('Ok, введите натуральное число N = ');
readln(n);
nt:=n;
sum:=0;
kw:=1;
while nt>=1 do
begin
temp:=nt mod 10;
sum := sum + temp;
kw:=kw * temp;
nt := nt div 10;
end;
if kw*kw=sum*sum*sum then
writeln('Квадрат произведения цифр числа ',n,' равняется кубу суммы его цифр')
else
writeln('Квадрат произведения цифр числа ',n,' НЕ равняется кубу суммы его цифр');
end.
Program Kasyanova98_3.1;
uses crt;
const n=10;
var
x,y:integer;
begin
writeln('********************************************************');
writeln('* ТАБЛИЦА УМНОЖЕНИЯ *');
writeln('********************************************************');
write('* * ');
for y:=1 to n do
begin
write(y:2);
if y
end;
writeln('********************************************************');
for x:=1 to n do
begin
write('* ',x:2, ' * ');
for y:=1 to n do
begin
write(x*y:2);
if y
if x*y<100 then writeln(' * ')
else writeln('* ');
if x<10 then writeln('+------------------------------------------------------+')
else writeln('********************************************************');
end;
end.
Program Kasyanova98_3.2;
uses crt;
const n=10;
var
x,y:integer;
begin
writeln('********************************************************');
writeln('* ТАБЛИЦА СЛОЖЕНИЯ *');
writeln('********************************************************');
write('* * ');
for y:=1 to n do
begin
write(y:2);
if y
end;
writeln('********************************************************');
for x:=1 to n do
begin
write('* ',x:2, ' * ');
for y:=1 to n do
begin
write(x+y:2);
if y
if x+y<100 then writeln(' * ')
else writeln('* ');
if x<10 then writeln('+------------------------------------------------------+')
else writeln('********************************************************');
end;
end.
- 16.01.2015 20:02
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.