Вопрос по информатике:
Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива
- 03.04.2018 19:40
- Информатика
- remove_red_eye 8111
- thumb_up 53
Ответы и объяснения 2
Случайным образом вводятся целые числа от 0 до 999.
max - максимальный элемент массива
i - цикловая переменная.
var
a : array [1..100] of integer;
max, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
max := a [ 1 ];
for i := 2 to n do
if a [ i ] > max then
max := a [ i ];
writeln (max + a [ 1 ])
end.
- 04.04.2018 07:14
- thumb_up 47
uses crt;
var
a:array [1..1000] of integer;
max,i,k:integer;
begin
write('Введи количество элементов массива: '); read(k);
for i:=1 to k do
begin
a[i]:=random(100)-50;
write(a[i]:4);
end;
writeln;
max:= a[1];
for i:=1 to k do
if a[i]>max then max:=a[i];
writeln('Максимальный элемент: ',max);
writeln ('Сумма первого и максимального элементов: ',max+a[1])
end.
- 05.04.2018 09:32
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.