Вопрос по информатике:
3. Составьте алгоритм вычисления значений функций для значений x=1, 2, 3, 4 …..10
- 23.01.2016 05:32
- Информатика
- remove_red_eye 17527
- thumb_up 30
Ответы и объяснения 1
В условии не указано, для какой именно функции вычислять значения. Я сочинил свою :)
Если тебе нужна другая функция, замени строку y:=(2*sin(x)+7*x*x)/sqrt(x); на то, что тебе нужно.
Program L1e2na_2;
uses crt;
var
x:integer;
y:real;
begin
writeln('+---------------------------------------+');
writeln('| КАКАЯ-ТО ФУНКЦИЯ |');
writeln('| Вычисление значения функции |');
writeln('| для Х = 1, 2, 3, ... , 10 |');
writeln('+---------------------------------------+');
writeln();
writeln('+---------------------------------------+');
writeln('| Результат: |');
writeln('+---------------------------------------+');
writeln('| X | Y |');
writeln('+---------------------------------------+');
for x:=1 to 10 do
begin
y:=(2*sin(x)+7*x*x)/sqrt(x);
writeln('| ',x:8,' | ',y:11:3,' | ');
end;
writeln('+---------------------------------------+');
end.
- 24.01.2016 04:20
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.