Вопрос по информатике:
Помогите. пожалуйста, сделась блок-схему и написать программу.... Дана матрица A(n*m). Найти номер строк, где все элементы кратны 5 и не кратны 3.
- 24.11.2017 12:29
- Информатика
- remove_red_eye 9629
- thumb_up 43
Ответы и объяснения 1
uses crt;
var a:array[1..100,1..100] of integer;
n,m,s:integer;
begin
clrscr;
randomize;
write('n='); read(n);
write('m='); read(m);
for n:=1 to n do
for m:=1 to m do
a[n,m]:=random(100);
writeln('massiv:');
for n:=1 to n do
begin
for m:=1 to m do
write(a[n,m],' ');
writeln;
end;
for n:=1 to n do
for m:=1 to m do
begin
if (a[n,m] mod 5 =0)and (a[n,m] mod 30) then
begin
s:=n;
write('stroka ',s,'; ');
end;
end;
end.
- 25.11.2017 10:09
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.