Вопрос по информатике:
Напишите программу, которая в последовательности натуральных
чисел определяет максимальное число, оканчивающееся на 3.
Программа получает на вход количество чисел в последовательности, а затем
сами числа. В последовательности всегда имеется число, оканчивающееся
на 3.
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число – максимальное число,
оканчивающееся на 3.
Пример работы программы:
Входные данные Выходные данные
3 23
13
23
3
23
- 19.05.2018 08:06
- Информатика
- remove_red_eye 18345
- thumb_up 84
Ответы и объяснения 2
var a:integer;
b:integer;
begin
b:=0;
readln(a);
while (a0) do
begin
if ((a mod 10=3) and (a>b)) then
b:=a;
readln(a);
end;
writeln(b);
readln
end.
- 19.05.2018 21:29
- thumb_up 52
CLS
a:
INPUT n
IF n < 1 OR INT(n) n OR n > 1000 THEN GOTO a
DIM a(n)
FOR i = 1 TO n
b:
INPUT a(n)
IF a(n) < 1 OR INT(a(n)) a(n) OR a(n) > 30000 THEN GOTO b
IF INT ((a(n) - 3 ) / 10) = ((a(n) - 3 ) / 10) AND a(n) > h THEN h = a(n)
NEXT i
PRINT h
END
- 21.05.2018 06:18
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.