Вопрос по информатике:
Составьте программу, заменяющую больше из двух данных чисел удвоенным произведением, а меньшее - полусуммой этих чисел
- 23.08.2016 00:21
- Информатика
- remove_red_eye 6197
- thumb_up 21
Ответы и объяснения 1
Var a,b,a1,b1:real;
begin
readln(a,b);
if a = b then writeln('Числа равны')
else
if a>b then begin
a1:=2*a*b; b1:=(a+b)/2;
a:=a1;b:=b1;
writeln('a = ',a,' b = ',b)
end
else begin
b1:=2*a*b; a1:=(a+b)/2;
a:=a1;b:=b1;
writeln('a = ',a,' b = ',b);
end;
end.
- 24.08.2016 09:06
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.