Вопрос по информатике:
Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.
- 13.07.2016 19:54
- Информатика
- remove_red_eye 18043
- thumb_up 18
Ответы и объяснения 1
var a:array[1..1000] of longint;
kol, s, i, n : longint;
begin
readln(n);
for i:=1 to n do read(a[i]);
s := 0;
kol := 0;
for i:=1 to n do
begin
if (a[i] mod 11 = 0) then s := s + a[i]; // summa elementov
if (a[i] mod 2 = 1) then kol := kol + a[i]; // kolichestvo nechetnyx
end;
writeln (kol, ' ', s);
end;
после // нужно удалить ... сорри, что нет блок схемы
- 14.07.2016 01:54
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.