Вопрос по информатике:
Составьте программу,которая запрашивает значения элементов одномерного числового массива А, состоящего из10 элементов, формирует и выводит на экран в строку данный массив.
Найти сумму элементов, кратных 3;
количество нулевых элементов;
и произведение элементов, стоящих на нечётных местах.
- 16.07.2018 02:42
- Информатика
- remove_red_eye 5538
- thumb_up 65
Ответы и объяснения 2
var
z,i,g,s:longint
a:array[0..100]of longint;
begin
z:=1;
for i:=1 to 10 do
begin
read(a[i]);
if a[i] mod 3=0 then inc(s,a[i]);
if a[i]=0 then inc(g);
if i mod 2>0 then z:=z*a[i];
write(a[i],' ');
end;
writeln;
writeln(s);
writeln(g);
writeln(z);
end.
- 17.07.2018 11:24
- thumb_up 23
Program Sarumyana;
const n=10;
var a:array[1..n] of integer;
tri, nol, odd, i: integer;
begin
writeln('*** alphaues is thinking... ***');
tri:=0;
nol:=0;
odd:=1;
for i:=1 to n do
begin
write('Введите ',i,'-e число ');
readln(a[i]);
if a[i] mod 3 = 0 then tri := tri + a[i];
if a[i] = 0 then nol := nol + 1;
if i mod 2 = 1 then odd := odd * a[i]
end;
write('Строка чисел: ');
for i:=1 to n do
begin
write(a[i],' ');
end;
writeln();
writeln('Сумма элементов, кратных 3, равна ',tri);
writeln('Количество нулевых элементов = ',nol);
writeln('Произведение элементов, стоящих на нечётных местах, = ',odd);
end.
- 18.07.2018 07:00
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.