Вопрос по информатике:
Помогите,пожалуйста, написать программу по теме "Ветвление в алгоритмах" для Pascal.
Задача: определить существует ли треугольник со сторонами ABC и, если существует, то какой он (равнобедренный, равносторонний, произвольный).
Заранее большое спасибо!
- 02.03.2018 23:02
- Информатика
- remove_red_eye 6333
- thumb_up 47
Ответы и объяснения 1
(*Pascal ABC.Net*)
program triangle;
var a,b,c: integer;
begin
write('Введите стороны:'); readln(a,b,c);
if (a=b) and (a=c) then
write('Треугольник равносторонний')
else if (a=b) or (b=c) or (a=c) then write('Треугольник равнобедренный')
else write('Треугольник произвольный');
end.
- 03.03.2018 22:59
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.