Вопрос по информатике:
В программе паскаль составить программу, выводящую на экран ряд чисел Фибоначчи.
Фибоначчи числа, элементы числовой возвратной последовательности 1, 1, 2, 3, 5, 8,... (ряда Фибоначчи), в которых каждый последующий член равен сумме двух предыдущих.
- 14.05.2018 13:20
- Информатика
- remove_red_eye 19663
- thumb_up 75
Ответы и объяснения 1
Program Fibonacci;
Uses Crt;
var i,n:integer;
{Итерационный метод вычисления чисел Фибоначчи}
function fib_it(n:integer):integer;
var a,b,c,i:integer;
begin
a:=1;b:=1;
if (n=1) or (n=2) then fib_it:=1
else begin
for i:=3 to n do
begin
c:=a+b;
a:=b;
b:=c;
end;
fib_it:=c;
end;
end;
{main program}
begin
clrscr;
write('Введите n: ');
readln(n);
for i:=1 to n do write(fib_it(i),' ');
readkey;
end.
- 14.05.2018 22:05
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.