Вопрос по информатике:
Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу: А*В = НОД(А*В)*НОК(А, В). (по алгоритму Евклида на Паскале)
- 22.08.2017 02:56
- Информатика
- remove_red_eye 12472
- thumb_up 87
Ответы и объяснения 1
Var
x, y, p: Integer;
begin
Writeln('Введите два числа');
Readln(x, y); {вводим два целых числа}
p := x * y;
repeat
if x > y Then x := x Mod y
Else y := y Mod x
until (x = 0) Or (y = 0);
{до тех пор, пока одно из чисел не станет равно нулю}
Writeln('НОK=', p / (x + y)); {вывод НОД - без условного оператора, так как одно из чисел обязательно равно нулю}
end.
- 23.08.2017 20:52
- thumb_up 67
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.