Вопрос по информатике:
помогите, пожалуйста. в паскале.
пусть в массиве содержатся результаты измерений температуры воздуха за декабрь, которые проводились ежедневно. определите сколько дней в декабре температура была выше средней.
- 17.06.2018 06:55
- Информатика
- remove_red_eye 17322
- thumb_up 97
Ответы и объяснения 1
const d = 31;
var
a: array[1..d] of integer;
i, count, mdl: integer;
begin
for i := 1 to d do begin
a[i] := random(31);
write(a[i], ' ');
mdl := mdl + a[i];
end;
writeln;
writeln('Средняя температура: ', (mdl / d):0:2);
for i := 1 to d do
if(a[i] > mdl / d) then inc(count);
writeln('Дни, в которые температура была выше средней: ', count);
end.
- 18.06.2018 13:04
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.