Вопрос по информатике:
1. Дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 – рост учащихся выпускного класса. В баскетбольную команду берут тех, чей рост не менее 180 см. Напишите программу, которая подсчитывает число претендентов в состав баскетбольной команды и выводит номера подходящих кандидатур.
- 11.09.2018 12:28
- Информатика
- remove_red_eye 6008
- thumb_up 94
Ответы и объяснения 2
Program Zn;
var m:array[1..30] of byte;
c,i:integer;
Begin
for i:=1 to 30 do begin
writeln('Введите рост кандидата');
Readln(m[i]);
if m[i]>=180 then inc(c)
end;
writeln('Количество подходящих кандидатур: ',c);
end.
(Программа проверена и откомпелирована на Pascal.NET, если есть вопросы, пишите)
- 12.09.2018 04:20
- thumb_up 13
const
n = 30;
var
a:array[1..n] of byte;
i, count:integer;
begin
randomize;
for i := 1 to n do
begin
a[i] := random(51) + 150;
writeln('Рост претендета № ', i:2, ' - ', a[i]);
end;
write('Номера подходящих кандидатур: ');
for i := 1 to n do
if a[i] >= 180 then
begin
inc(count);
write(i, ' ');
end;
writeln;
writeln('Общее количество подходящих претендентов: ', count);
end.
- 13.09.2018 05:22
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.