Вопрос по информатике:
В ПАСКАЛЬ АБС.
В ЭВМ поступают результаты соревнований по плаванию для трех спортсменов. Составьте программу, которая выбирает лучшей результат и выводит его на экран с сообщением, что это лучшей результат.
- 01.02.2018 09:29
- Информатика
- remove_red_eye 7581
- thumb_up 86
Ответы и объяснения 2
var i :integer;
a, b:real;
begin
for i:=1 to 3 do
begin
write ('a=');
readln(a);
if (a>b) then b:=a;
end;
writeln ('a=' , b);
end.
- 02.02.2018 20:19
- thumb_up 42
const
N = 3;
var
a: array[1..N] of integer;
i, max: integer;
begin
max := 0;
writeln('Введите результаты трех спортсменов');
for i := 1 to N do readln(a[i]);
for i := 1 to N do
begin
if a[i] > max then
max := a[i];
end;
writeln;
writeln('Лучший результат среди трех спортсменов - ', max);
end.
- 03.02.2018 11:42
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.