Вопрос по информатике:
1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и вывести список книг, изданных после 2003 года.
2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.
- 11.02.2016 07:23
- Информатика
- remove_red_eye 4115
- thumb_up 42
Ответы и объяснения 1
Сделано для трёх книг, потом поменяешь в двух местах
PROGRAM prim2;
uses crt;
Type
book=record
avtor: string[20];
name:string[25];
year:integer;
end;
Var
f,i: integer;
b:array[1..3] of book;
BEGIN
clrscr;
f:=0;
{формирование записей}
for i:=1 to 3 do
Begin
write('Введите название книги: ');
readln(b[i].name);
write('Введите фамилию автора: ');
readln(b[i].avtor);
write('Введите год издания: ');
readln(b[i].year);
end;
writeln;
Writeln('Сведения о книгах (автор,название,год издания) год издания которых позже 1990');
for i:=1 to 3 do
Begin
if b[i].year>2003 then {проверка условия задачи}
Begin
f:=f+1;
Writeln(f:6,' ', b[i].avtor,' ', b[i].name,' ', b[i].year);
end;
end;
writeln('Итог: ',f);
readln;
END.
- 11.02.2016 21:33
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.