Вопрос по информатике:
Напишите программу, которая находит произведение двух наибольших чисел из последовательности натуральных чисел. Программа получает на вход натуральные числа, количество чисел неизвестно (но не менее двух), ввод последовательности заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Значения чисел не превышают 30000. Программа должна вывести одно число: произведение двух чисел, значения которых в данной последовательности наибольшие
- 06.01.2018 09:06
- Информатика
- remove_red_eye 12731
- thumb_up 68
Ответы и объяснения 1
var temp,max,max2:integer;
begin
readln(temp);
max:=0;
max2:=0;
while (temp0) do begin
if(temp>max) then begin max2:=max; max:=temp; end
else if(temp>max2) then max2:=temp;
readln(temp);
end;
writeln(max*max2)
end.
- 06.01.2018 23:03
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.