Вопрос по информатике:
Дан массив a состоящий из n
целых чисел. Требуется найти количество пар соседних элементов массива, являющихся четными числами.
Формат входных данных
На первой строке записано целое число n (0
На второй строке через пробел записаны n
чисел (−1000≤ai≤1000)
— элементы массива.
Формат выходных данных
Требуется вывести единственное число — количество пар четных чисел.
- 20.10.2015 18:00
- Информатика
- remove_red_eye 11934
- thumb_up 46
Ответы и объяснения 1
Var
i, k, n: integer;
a: array[1..10000]of integer;
begin
k := 0;
readln(n);
for i := 1 to n do read(a[i]);
for i := 2 to n do if (a[i - 1] mod 2 = 0) and (a[i] mod 2 = 0) then k := k + 1; write(k);
end.
- 21.10.2015 06:11
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.