Вопрос по информатике:
тема: Цикл с предусловием. Задание :Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры.
в паскале напишите программу плиз
- 17.11.2016 21:57
- Информатика
- remove_red_eye 7398
- thumb_up 68
Ответы и объяснения 1
Program A;
uses crt;
var
s: string;
k,j,f: integer;
ch: char;
begin
read(S);
f:=0;
for k:=1 to length(s) do
for j:=1 to length(s) do
if ((s[k]=s[j]) and (kj)) then begin f:=1; ch:=s[k]; end;
if f=1 then Writeln('YES - ',ch) else write('NO');
readln;
End.
- 19.11.2016 06:59
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.