Вопрос по информатике:
Даны две дроби А/В и С/D (A,В,C,D — натуральные числа). Составьте программу вычитания из первой дроби второй. Ответ должен быть несократимой дробью. ИСПОЛЬЗОВАТЬ ПОДПРОГРАММУ АЛГОРИТМА ЕВКЛИДА для определения НОД.
- 13.10.2017 05:25
- Информатика
- remove_red_eye 3146
- thumb_up 13
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
function Euclid(a,b:integer):integer;
begin
while ab do if a>b then a-=b else b-=a;
Result:=a
end;
begin
var a,b,c,d:integer;
Write('Числитель и знаменатель первой дроби: ');
Read(a,b);
Write('Числитель и знаменатель второй дроби: ');
Read(c,d);
var zn:=b*d;
var ch:=a*d-c*b;
var sgn:=Sign(ch); ch:=Abs(ch);
var gcd:=Euclid(ch,zn);
Write('Результат вычитания: ');
if sgn=-1 then Write('-');
Writeln(ch div gcd,'/',zn div gcd)
end.
Тестовое решение:
Числитель и знаменатель первой дроби: 7 12
Числитель и знаменатель второй дроби: 3 4
Результат вычитания: -1/6
- 14.10.2017 18:08
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.