Вопрос по информатике:
Помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 – сложение, 2 – вычитание, 3 – умножение, 4 – деление. Дан номер действия n и вещественные числа a, b (b<>0). Выполнить над числами указанное действие и вывести результат. Например, n=2, а=0,40, в=1,00. Результат: а-в=-0,60. Единицы длины пронумерованы так: 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр. Дан номер единицы длины и длина отрезка в этих единицах (вещественное число). Найти длину отрезка в метрах.
- 12.03.2018 04:34
- Информатика
- remove_red_eye 18234
- thumb_up 86
Ответы и объяснения 2
var
d:integer;
a,b:real;
begin
write('a = '); readln(a);
write('b = '); readln(b);
write('Введите номер операции '); readln(d);
case d of
1: writeln(a, ' + ', b, ' = ', a + b);
2: writeln(a, ' - ', b, ' = ', a - b);
3: writeln(a, ' * ', b, ' = ', a * b);
4: begin
if b 0 then
writeln(a, ' / ', b, ' = ', a / b)
else
writeln('делить на 0 нельзя');
end;
else
writeln('Неизвестная операция');
end;
end.
//вторая программа
var
d:integer;
a:real;
begin
write('Длина отрезка = '); readln(a);
write('Введите код единицы измерения '); readln(d);
case d of
1: writeln('Длина отрезка ', a / 10, ' метр(а, ов)');
2: writeln('Длина отрезка ', a * 1000, ' метр(а, ов)');
3: writeln('Длина отрезка ', a, ' метр(а, ов)');
4: writeln('Длина отрезка ', a / 1000, ' метр(а, ов)');
5: writeln('Длина отрезка ', a / 100, ' метр(а, ов)');
else
writeln('Неизвестная единица длины');
end;
end.
- 13.03.2018 21:22
- thumb_up 7
{ 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр.}
var
units: integer;
value, factor: real;
begin
write('Введите значение - '); readln(value);
write('Введите единицу измерения - '); readln(units);
case units of
1: factor := 0.1;
2: factor := 1000;
3: factor := 1;
4: factor := 0.001;
5: factor := 0.01;
else
factor := 1;
end;
writeln(value * factor, ' м');
end.
- 14.03.2018 06:55
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.